Installing 8.5.0 FP1 on Ubuntu Server

I have been upgrading a development server running on Ubuntu 8.04 from 8.5.0 to 8.5.0. FP1 ( yes I know that it is not supported )

The standard install for the fix pack does not work and gives the following errors :

@ts13-001:~/Desktop/linux$ cd domino
@ts13-001:~/Desktop/linux/domino$ sudo ./install
[sudo] password for :
[: 160: TOOLS/NLS/-E: unexpected operator

[: 160: tools/nls/-e: unexpected operator

[: 160: tools/nls/-e;1: unexpected operator

.: 1: -e: not found

after much hunting about I came across this fix by Matt Schmandt

Domino 8.5 can be installed on Ubuntu 8.04 but you need to perform an extra step.

From the command line run “sudo su” and then run “./install”.

#Example
sudo su
./install

Once I tried this everything worked fine. Next time I might look at Roverex which was suggested by Johann Echanarr.

“Roverex is a derivative Ubuntu distribution that has been created to integrate IBM Lotus Software with Ubuntu, specifically Lotus Domino Server, Lotus Notes Client and Lotus Symphony.

Roverex is an open source project so anyone that want to contribute is welcome, any feedback/testing will be appreciated and right now there’s need for a Spanish/Italian translator, so please send an email to roverex-dev at roverex dot org to be part of our Roverex community.

IBM Lotus Domino Server and Lotus Notes Client provide a secure email, scheduling, calendaring, messaging/chat platform and an application development server.

IBM Lotus Symphony is an Office open source alternative suite that is intuitive and easy to use, which ensure access to documents well into the future with new standard file formats (ODF), and save existing investments with support for Microsoft

8.5.1 – Iā€™m impressed by the way that IBM is listening behind the scenes

I have been very fortunate to have recently become involved in the the Design Partner Program. It has been an interesting and somewhat confusing time to join because the program is moving towards the release of 8.5.1 at a great pace and there is a huge amount of stuff that has already happened.

As with any project of this scale ( and particularly being a newbie ) it is always possible to find things that could be better but by far the biggest thing that has impressed me is the way in which IBM is prepared to listen to its Design Partners, not just for 8.5.1 but also for 8.5.x and beyond – imagine a scene where IBM Engineers pitch ideas to customers and business partners, taking polls and actively looking for feedback on open mic conference calls.

Over the last few days you will have seen some pretty clued up people beginning to blog about 8.5.1. They are not only very clued up on the technical aspects of the release but also have good insights into where IBM can best add value to organisations and end users. They are all working closely with IBM to ensure that Notes is as good as it can be and for each person that does blog there are quite a few others that are not able to blog.

Why am I blogging this ?  Well I am genuinely really impressed ( and pleasantly surprised ) at what I have seen. The Lotus Knows Idejam was really impressive but it has also been good to see that there are other long established collaborative processes already in place.

I am not sure why people don’t blog about the process ( as opposed to the secret content ) more. I guess that the Design Partners have been instructed not to release any IBM confidential information and the existence of such successful collaboration between IBM and its customers must be seen as confidential šŸ˜‰  

simple xpages thing – what am I doing wrong ?

update :   This now works fine under 8.5.1 Beta ( CD8 ) out of the box so the problems has gone away

OK, this should be trivial, what am I doing wrong ??

I can’t get the post save event to run an agent but I can run it via a button.

I have an Xpage here >> http://www.seancull.co.uk/Public/Examples/agenttest.nsf/simplexpage.xsp

which is very simple. It is bound to a form with a single field and has two buttons. There is a post save event which should run an agent which also creates a new agent log document. i.e. TWO documents should be created. The agent log document does not have a form name when displayed in the view.

New documents appear in the view.

When I press the button to runt he agent a new formless document ( i.e the agent log ) is created – great

When I save the document the back end agent does not run – i.e. no formless ( i.e. agent log ) document

I am doing something really stupid – what is it ?

some screenshots of the setup and the code is at the end

Image:simple xpages thing - what am I doing wrong ?
Image:simple xpages thing - what am I doing wrong ?

Image:simple xpages thing - what am I doing wrong ?

update – screen shot of button properties as mentioned by Graeme below – although there is a workaround I still don’t understand it the problem is me or xpages ?

Image:simple xpages thing - what am I doing wrong ?